互联网安全十分重要,网站认证能够提升网站可信度。

WordPress翻译无法更新最有效的2种解决方法

网站建设 李胜利 88℃ 0评论

李胜利博客的独特优势之一就是WordPress不是一个固定的系统,而是会在官方强大的技术实力基础上,不定期地更新升级其版本,包括程序功能、安全性、性能优化等等,在WordPress每次更新后,我们都是强烈建议客户第一时间进行WordPress的更新操作,保证其网站WordPress版本始终是在最新版,从而使得网站保持最好的系统状态。

在部分用户更新WordPress时,如果使用的不是英文版,而且其他语言版本,如简体中文版,则可能会出现以下的翻译错误提示:

正在更新WordPress(zh_CN)的翻译…
无法安装这个包。 PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
返回“WordPress更新”页面

遇到这一问题的话,有2种解决方法。

方法1:人工更新

访问WordPress官方网站 www.wordpress.org/download 页面,下载最新版本的程序包,解压后打开 /wp-content/languages 目录,将该目录下的所有语言包文件上传到服务器的同样文件目录覆盖更新即可。

方法2:修改主机(服务器)php.ini文件

2.1 在的主机(服务器)的 php的配置文件:php.ini 中搜索并找到 disable_functions;
2.2 删除 disable_functions 后面的 scandir 字符串,保存 php.ini;
2.3 重载或重启 php-fpm 服务即可:service php-fpm reload 。
完成以上操作后,在网站后台就可以直接更新翻译了。

转载请注明:李胜利博客 » WordPress翻译无法更新最有效的2种解决方法

喜欢 (1)or分享 (0)
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址