互联网安全十分重要,网站认证能够提升网站可信度。

两步解决wordpress4.0以上版本标签无法打开

网络技术 李胜利 1884℃ 0评论

用过wordpress的朋友一定知道,在标签云中点击中文标签就会出现找不到文章的情况。

就是由于wordpress对中文标签支持不好的原因。

下面李胜利就介绍一下两步解决wordpress4.0以上版本标签无法打开的具体操作步骤(本人就是这样解决的)。

步骤一:

打开WP-include/class-wp.php(wordpress4.0版本)如下图所示:

20150224151134

  找到第153行,把:

$pathinfo = isset( $_SERVER[‘PATH_INFO’] ) ? $_SERVER[‘PATH_INFO’] : ”;

替换为:

$pathinfo = mb_convert_encoding($_SERVER[‘PATH_INFO’], ‘UTF-8’, ‘GBK’);

步骤二

仍然打开WP-include/class-wp.php(wordpress4.0版本)如下图所示:

20150224151010

  找到第157行,把:

list( $req_uri ) = explode( ‘?’, $_SERVER[‘REQUEST_URI’] );

替换为

$req_uri = mb_convert_encoding($_SERVER[‘REQUEST_URI’], ‘UTF-8’, ‘GBK’);

李胜利,著名自媒体人;著名互联网评论人,胜利传媒创始人/CEO,胜利品牌创始人;巨推俱乐部理事公众微信号:lishengli-china;微信号:lishenglicom;QQ:494269215转载请注明作者姓名和“来源:李胜利博客”。

dashangtu

转载请注明:李胜利博客 » 两步解决wordpress4.0以上版本标签无法打开

喜欢 (1)or分享 (0)
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(4)个小伙伴在吐槽
  1. 我刚刚试过了, 真的可以也!!!李老师真的是个全才啊!!!!
    七雪2015-02-24 15:31 回复
  2. wordpress升级到4.0发现无法识别
    特洛伊Kyoya2015-02-24 15:44 回复
  3. wordpress升级到4.0发现无法识别
    特洛伊Kyoya2015-02-25 07:36 回复
    • 你是从什么版本升到4.0的,可能是版本跨度太大了缘故吧!要不你就手动升级一下!!
      活雷锋2015-02-24 16:50 回复